Bridge ARP flood

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Uldis (UD)
Posts: 1492
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Bridge ARP flood

Post by Uldis (UD) » Wed Mar 07, 2018 8:26 pm

use on your switch:
no ip cef

btw I tested another IOL SW image, same no issues all works perfect
NO ONE of my IOL SW images makes any collisions NO ONE..

BTW where is your eve installed??? is it VM machine or what

nio-12
Posts: 10
Joined: Mon Mar 05, 2018 8:51 am

Re: Bridge ARP flood

Post by nio-12 » Thu Mar 08, 2018 9:02 am

My Eve is Bare Installation on hardware with Ubuntu 16.04 sever.

I will be able to test "no ip cef" on Monday (12.03.2018), my working server will be unavalable for 3 days.

Thank you, I will tell the result.

Uldis (UD)
Posts: 1492
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Bridge ARP flood

Post by Uldis (UD) » Thu Mar 08, 2018 10:48 am

I have tested and BARE EVE and ESXi VM, same result no issues....

nio-12
Posts: 10
Joined: Mon Mar 05, 2018 8:51 am

Re: Bridge ARP flood

Post by nio-12 » Mon Mar 12, 2018 8:09 am

I tried "no ip cef".

The result is the same, I get arp flood.

Here is a full config of router and switches.

Code: Select all

!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone MSK 3 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!


!
!
!
!
no ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
! 
!
!
!
!
!
!
!
!
bridge irb
!
!
!
!
interface Ethernet0/0
 no shutdown
 no ip address
 bridge-group 1
!
interface Ethernet0/1
 no shutdown
 no ip address
 bridge-group 1
!
interface Ethernet0/2
 no shutdown
 no ip address
 bridge-group 1
!
interface Ethernet0/3
 no shutdown
 no ip address
 shutdown
!
interface BVI1
 no shutdown
 ip address 140.0.0.4 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input none
!
!
end

Code: Select all


!
! Last configuration change at 10:48:06 MSK Mon Mar 12 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone MSK 3 0
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no shutdown
!
interface Ethernet0/1
 no shutdown
!
interface Ethernet0/2
 no shutdown
!
interface Ethernet0/3
 no shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
The process is shown in attachment.

I also test it on EVE VM machine.

Any ideas?
You do not have the required permissions to view the files attached to this post.

nio-12
Posts: 10
Joined: Mon Mar 05, 2018 8:51 am

Re: Bridge ARP flood

Post by nio-12 » Tue Mar 13, 2018 9:57 am

I have tested my bridge in GNS3 and it works fine.

Why my bridge works in GNS3?

And why it does not work in EVE-NG?

What I am doing wrong?

Can anybody give me to test L2 image that exactly work in EVE-NG with this bridge?
You do not have the required permissions to view the files attached to this post.

Uldis (UD)
Posts: 1492
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Bridge ARP flood

Post by Uldis (UD) » Tue Mar 13, 2018 7:41 pm

find me in live EVE chat.
http://www.eve-ng.net/index.php/live-helpdesk

UD-EVE

nio-12
Posts: 10
Joined: Mon Mar 05, 2018 8:51 am

Re: Bridge ARP flood

Post by nio-12 » Wed Mar 14, 2018 12:02 pm

The problem was with L2 image.

I have change it to the correct L2 image and all started to work good.

Thanks to Uldis (UD, UD-EVE in live chat)! He helped me to solve the problem.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests